백준 온라인 저지, 자료구조 / 10828번: 스택 (파이썬)

2021. 9. 1. 00:58알고리즘/자료구조

728x90
반응형

문제

https://www.acmicpc.net/problem/10828

문제 정의

정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 다섯 가지이다.

입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.

출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

예제 입력 1

14
push 1
push 2
top
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
top

예제 출력 1

2
2
0
2
1
-1
0
1
-1
0
3

접근 방법

 

코드

import sys
n = int(sys.stdin.readline())
orders = [list(sys.stdin.readline().split()) for _ in range(n)]
# n = 14
# orders = [['push', '1'], ['push', '2'], ['top'], ['size'], ['empty'], ['pop'], ['pop'], ['pop'], ['size'], ['empty'], ['pop'], ['push', '3'], ['empty'], ['top']]

stack = []
for order in orders:
    if order[0] == 'push':
        stack.append(int(order[1]))

    elif order[0] == 'pop':
        if stack:
            x = stack.pop()
            print(x)
        else:
            print(-1)

    elif order[0] == 'size':
        print(len(stack))
    
    elif order[0] == 'empty':
        if stack:
            print(0)
        else:
            print(1)
    elif order[0] == 'top':
        if stack:
            print(stack[-1])
        else:
            print(-1)
728x90
반응형